What’s Vulnerable › Vulnerabilities

CVE-2026-6644: A command injection vulnerability was found in the PPTP VPN Clients on the ADM

Description

A command injection vulnerability was found in the PPTP VPN Clients on the ADM. The vulnerability allows an administrative user to break out of the restricted web environment and execute arbitrary code on the underlying operating system. This occurs due to insufficient validation of user-supplied input before it is passed to a system shell. Successful exploitation allows an attacker to achieve Remote Code Execution (RCE) and fully compromise the system. Affected products and versions include: from ADM 4.1.0 through ADM 4.3.3.RR42 as well as from ADM 5.0.0 through ADM 5.1.2.REO1.

Affected products

How to fix

Upgrade to a fixed version: Tenable ASUSTOR Data Master 4.3.3.RR42, 5.1.2.reo1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-6644 or the next vulnerability affects your stack