What’s Vulnerable › Vulnerabilities
CVE-2026-6664: PgBouncer integer overflow in PgBouncer network packet parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-190
Description
An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.
Affected products
- PgBouncer: before 1.25.2 — fixed in 1.25.2
How to fix
Upgrade to a fixed version: PgBouncer 1.25.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6664 or the next vulnerability affects your stack