What’s Vulnerable › Vulnerabilities
CVE-2026-6665: PgBouncer buffer overflow in SCRAM
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-09 · updated 2026-07-24
- Weakness: CWE-121
Description
The SCRAM code in PgBouncer before 1.25.2 did not check the return value of strlcat() correctly when building the contents of the SCRAM client-final-message. A malicious backend that sends a SCRAM server-final-message with a long nonce can trigger a stack overflow.
Affected products
- PgBouncer: before 1.25.2 — fixed in 1.25.2
How to fix
Upgrade to a fixed version: PgBouncer 1.25.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6665 or the next vulnerability affects your stack