What’s Vulnerable › Vulnerabilities
CVE-2026-66723: Missing authentication requirement in Remote Instances proxy API in MWDB Core
- Severity: high (CVSS 7.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-10-23
- Weakness: CWE-862
Description
MWDB Core versions >=2.2.0 and <2.19.0 contain a missing authorization vulnerability in the Remote Instances proxy API. The proxy API does not verify authentication for incoming requests, allowing an unauthenticated remote attacker to send arbitrary requests to a remote MWDB instance using the identity and permissions associated with the configured API key. This can result in unauthorized actions being performed on the remote instance as if executed by the user whose API key was used to set up the remote instance. The vulnerability is limited to deployments where Remote Instances have been configured.This issue has been fixed in version 2.19.0
Affected products
- CERT.PL MWDB Core: from 2.2.0 before 2.19.0 — fixed in 2.19.0
How to fix
Upgrade to a fixed version: CERT.PL MWDB Core 2.19.0. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2026/07/CVE-2026-66723
- https://github.com/CERT-Polska/mwdb-core/releases/tag/v2.19.0
- https://github.com/CERT-Polska/mwdb-core/security/advisories/GHSA-942c-r7qj-w895
Get alerted when CVE-2026-66723 or the next vulnerability affects your stack