What’s Vulnerable › Vulnerabilities
CVE-2026-66738: SPIP < 4.4.18 Code Injection via Navigation Endpoint on SQLite
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-09-09
- Weakness: CWE-94
Description
SPIP before 4.4.18 contains a code injection vulnerability in SQLite-backed installations. The navigation menu endpoint improperly handles array-typed user input, which bypasses input sanitization and allows the value to break out of an internal quoted string context when evaluated as PHP. An authenticated attacker with at minimum editor (redacteur) privileges can submit a single crafted GET request to /ecrire/?exec=navigation to execute arbitrary OS commands in the web server process. MySQL-backed installations are not affected.
Affected products
- SPIP: before 4.4.18 — fixed in 4.4.18
How to fix
Upgrade to a fixed version: SPIP 4.4.18. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/Mise-a-jour-critique-de-securite-sortie-de-SPIP-4-4-18.html
- https://www.vulncheck.com/advisories/spip-code-injection-via-navigation-endpoint-on-sqlite
Get alerted when CVE-2026-66738 or the next vulnerability affects your stack