What’s Vulnerable › Vulnerabilities
CVE-2026-66776: Multiple vulnerabilities in SAP Business AI Platform (Approuter)
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-24
- Weakness: CWE-347
Description
SAP Approuter does not consistently enforce integrity verification on certain session-related request headers under specific conditions. An attacker with low privileges could send a specially crafted request that bypasses the integrity check and loads another user's session context. Successful exploitation requires the attacker to have previously observed matching session values out-of-band, which makes the attack complex to execute. This could result in a high impact on confidentiality and a low impact on integrity. There is no impact on availability.
Affected products
- SAP_SE SAP Business AI Platform (Approuter): before 23.0.0 — fixed in 23.0.0
How to fix
Upgrade to a fixed version: SAP_SE SAP Business AI Platform (Approuter) 23.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-66776 or the next vulnerability affects your stack