What’s Vulnerable › Vulnerabilities
CVE-2026-67194: Courier IMAP < 6.0.1 Mail Server < 2.0.2 Stack Overflow DoS via Nested SEARCH Queries
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-07-30
- Weakness: CWE-674
Description
Courier IMAP before 6.0.1 and Courier Mail Server before 2.0.2 allow authenticated IMAP users to crash the imapd process via deeply nested parenthesized SEARCH queries. The SEARCH command parser (alloc_search_key in searchinfo.C) recursively descends on nested parenthesized groups through a mutual recursion chain with alloc_search_andlist() and alloc_search_notkey(), with no depth limit. Courier IMAP has no overall command line length limit, making exploitation trivial. A single IMAP command with ~2500 nested parentheses overflows the 8MB default stack, causing SIGSEGV.
Affected products
- svarshavchik Courier IMAP: before 6.0.1 — fixed in 6.0.1
- svarshavchik Courier Mail Server: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: svarshavchik Courier IMAP 6.0.1; svarshavchik Courier Mail Server 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/svarshavchik/courier-libs/commit/b5b5581aabea3efadf5e2944947ff0214aa3533e
- https://github.com/svarshavchik/courier/releases/tag/courier%2F2.0.2%2F20260627214309
- https://github.com/svarshavchik/courier/releases/tag/courier-imap%2F6.0.1%2F20260627214444
- https://packages.debian.org/sid/courier-imap
- https://www.vulncheck.com/advisories/courier-imap-mail-server-stack-overflow-dos-via-nested-search-queries
Get alerted when CVE-2026-67194 or the next vulnerability affects your stack