What’s Vulnerable › Vulnerabilities
CVE-2026-67221: RabbitMQ: AMQP 1.0 shovel status exposes plaintext URI passwords
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-10-19
- Weakness: CWE-312
Description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The AMQP 0-9-1 shovel calls amqp_uri:remove_credentials before storing its connection URI, but the AMQP 1.0 shovel stores the raw URI including the password. The stored URI is visible via GET /api/shovels and via rabbitmqctl shovel_status. Preconditions include The Shovel plugin must be in use with AMQP 1.0 shovels configured using URI-embedded credentials. Reading the exposed status requires the monitoring tag.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Affected products
- rabbitmq-server: from 3.13.0 before 3.13.15; from 4.0.0 before 4.0.20; from 4.1.0 before 4.1.11; from 4.2.0 before 4.2.6 — fixed in 3.13.15, 4.0.20, 4.1.11, 4.2.6
How to fix
Upgrade to a fixed version: rabbitmq-server 3.13.15, 4.0.20, 4.1.11, 4.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-x5h5-588r-cv55
Get alerted when CVE-2026-67221 or the next vulnerability affects your stack