What’s Vulnerable › Vulnerabilities
CVE-2026-67222: RabbitMQ: list_to_atom on auth_mechanism URI tokens in amqp_client
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-15
- Weakness: CWE-400
Description
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15, 4.0.20, 4.1.11, and 4.2.6, mechanisms/1 applied list_to_atom/1 to every colon-delimited token in an attacker-controlled auth_mechanism value, permanently consuming Erlang VM atoms and allowing the node to be crashed with a large request. Exploitation requires the Shovel or Federation plugin to be in use, and setting auth_mechanism requires the policymaker tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
Affected products
- rabbitmq-server: from 3.13.0 before 3.13.15; from 4.0.0 before 4.0.20; from 4.1.0 before 4.1.11; from 4.2.0 before 4.2.6 — fixed in 3.13.15, 4.0.20, 4.1.11, 4.2.6
How to fix
Upgrade to a fixed version: rabbitmq-server 3.13.15, 4.0.20, 4.1.11, 4.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-85jr-6rr2-j73r
Get alerted when CVE-2026-67222 or the next vulnerability affects your stack