What’s Vulnerable › Vulnerabilities
CVE-2026-67227: RabbitMQ: Atom exhaustion: to_atom on global-parameter :name
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-20
- Weakness: CWE-400
Description
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1, Atom exhaustion: toatom on global-parameter :name. resourceexists/2 (and the PUT/DELETE handlers) call rabbitdatacoercion:toatom/1 on the :name URL path segment. toatom/1 uses binarytoatom/2 (unsafe). The endpoint requires policymaker (not management, but below A user with the policymaker tag can crash the node by exhausting the atom table via repeated requests to /api/global-parameters/:name with unique :name Management plugin enabled policymaker tag ~1M HTTP. This issue is fixed in versions 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1.
Affected products
- rabbitmq-server: from 4.0.0 before 4.0.22; from 4.1.0 before 4.1.14; from 4.2.0 before 4.2.7; from 4.3.0 before 4.3.1 — fixed in 4.0.22, 4.1.14, 4.2.7, 4.3.1
How to fix
Upgrade to a fixed version: rabbitmq-server 4.0.22, 4.1.14, 4.2.7, 4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/8fbe6d8112427e85fb9a9206b3eb6e9a3ddd3e39
- https://github.com/rabbitmq/rabbitmq-server/commit/fc591e7ee27a29657ca960930acefd3e4217e007
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.7
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.1
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-q7x8-97rh-cr24
Get alerted when CVE-2026-67227 or the next vulnerability affects your stack