What’s Vulnerable › Vulnerabilities
CVE-2026-67230: RabbitMQ: Web-STOMP unbounded pre-auth accumulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-20
- Weakness: CWE-770
Description
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.15, 4.0.20, 4.1.11, and 4.2.6, the Web STOMP WebSocket handler enforced neither max_frame_size nor login_timeout before authentication, allowing an unauthenticated client to keep a connection alive with a slow stream of small frames and accumulate unbounded pre-authentication state. The rabbitmq_web_stomp plugin must be enabled, and no authentication is required to reach the vulnerable path. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
Affected products
- rabbitmq-server: from 3.13.0 before 3.13.15; from 4.0.0 before 4.0.20; from 4.1.0 before 4.1.11; from 4.2.0 before 4.2.6 — fixed in 3.13.15, 4.0.20, 4.1.11, 4.2.6
How to fix
Upgrade to a fixed version: rabbitmq-server 3.13.15, 4.0.20, 4.1.11, 4.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/0b4080fa5d6f797b6331d0ce1db2b4bacd34560e
- https://github.com/rabbitmq/rabbitmq-server/commit/8138edae6d2beaafe699a41a754d17420bdc2068
- https://github.com/rabbitmq/rabbitmq-server/commit/c1000ba89052608c01c052d98016403ba6e92222
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-7v63-j4gm-p4rh
Get alerted when CVE-2026-67230 or the next vulnerability affects your stack