What’s Vulnerable › Vulnerabilities
CVE-2026-67234: RabbitMQ: Non-RFC-conformant cookie name when clearing the auth-mechanism preference
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-20
- Weakness: CWE-20
Description
RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.8 and 4.3.2, get_auth_mechanism/1 used term_to_binary/1 on the strict_auth_mechanism or preferred_auth_mechanism atom when clearing the corresponding cookie, producing a non-ASCII cookie name that violates RFC 6265 and can prevent the browser from deleting the preference. The issue is not directly exploitable for code execution or data exfiltration; its security relevance is limited to stale authentication-mechanism preferences persisting across logout and login cycles. This issue is fixed in versions 4.2.8 and 4.3.2.
Affected products
- rabbitmq-server: from 4.2.0 before 4.2.8; from 4.3.0 before 4.3.2 — fixed in 4.2.8, 4.3.2
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.8, 4.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/149cb59d618cefa83c6deb02dbbb1e8a7a2bc968
- https://github.com/rabbitmq/rabbitmq-server/commit/baac0aaf170efeb4f124ee36b8417274fa8dcc1a
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.8
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.2
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-q286-p3m9-j69f
Get alerted when CVE-2026-67234 or the next vulnerability affects your stack