What’s Vulnerable › Vulnerabilities
CVE-2026-67261
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-10-24
- Weakness: CWE-78
Description
Dell Virtual Storage Integrator for VMware vSphere Client, versions prior to 10.11.1.0, contain(s) an OS Command Injection vulnerability in the IAPI component. A remote unauthenticated attacker could potentially exploit this vulnerability, leading to the execution of arbitrary OS commands on the application's underlying operating system with root privileges. Exploitation may lead to a complete system takeover by an attacker. This vulnerability is considered critical as it allows an unauthenticated remote attacker to achieve arbitrary code execution as root, potentially compromising the entire VSI deployment and underlying infrastructure. Dell recommends customers to upgrade at the earliest opportunity.
Affected products
- Dell Virtual Storage Integrator for VMware vSphere Client: before 10.11.1.0 — fixed in 10.11.1.0
How to fix
Upgrade to a fixed version: Dell Virtual Storage Integrator for VMware vSphere Client 10.11.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-67261 or the next vulnerability affects your stack