What’s Vulnerable › Vulnerabilities
CVE-2026-67296: FreeRDP before 3.29.0 Denial of Service via RDPEI PDU
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-01 · updated 2026-09-11
- Weakness: CWE-20
Description
FreeRDP before 3.29.0 contains a denial of service vulnerability in the RDPEI server channel handler that fails to validate maximum PDU body length before stream allocation. A malicious RDP client can send a header-only RDPEI message with a large declared body length to force excessive memory allocation on the server.
Affected products
- FreeRDP: before 3.29.0 — fixed in 3.29.0
How to fix
Upgrade to a fixed version: FreeRDP 3.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-jm8r-22j6-4m4v
- https://www.vulncheck.com/advisories/freerdp-before-denial-of-service-via-rdpei-pdu
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-jm8r-22j6-4m4v
Get alerted when CVE-2026-67296 or the next vulnerability affects your stack