What’s Vulnerable › Vulnerabilities
CVE-2026-67312: axios 0.28.0 before 0.33.0 and 1.0.0 before 1.18.0 Denial of Service via formToJSON
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-01 · updated 2026-10-29
- Weakness: CWE-400
Description
axios versions from 0.28.0 before 0.33.0 and from 1.0.0 before 1.18.0 contain uncontrolled recursion in formDataToJSON (exposed as axios.formToJSON() and used internally when serializing FormData with Content-Type: application/json). When an application passes attacker-controlled FormData field names, a field name with thousands of nested bracket-delimited segments causes unbounded recursion in buildPath(), exhausting the JavaScript call stack (RangeError: Maximum call stack size exceeded) and causing denial of service for that request, or process termination in applications without appropriate error handling.
Affected products
- axios: from 0.28.0 before 0.33.0; from 1.0.0 before 1.18.0 — fixed in 0.33.0, 1.18.0
- axios: from 0.28.0 before 0.33.0 — fixed in 0.33.0
How to fix
Upgrade to a fixed version: axios 0.33.0, 1.18.0; axios 0.33.0. Check the vendor advisory for mitigations.
References
- https://github.com/axios/axios/security/advisories/GHSA-pmv8-rq9r-6j72
- https://www.vulncheck.com/advisories/axios-before-denial-of-service-via-formtojson
- https://github.com/axios/axios/security/advisories/GHSA-pmv8-rq9r-6j72
Get alerted when CVE-2026-67312 or the next vulnerability affects your stack