What’s Vulnerable › Vulnerabilities
CVE-2026-67313: axios 0.28.0 before 1.18.0 Denial of Service via formDataToJSON
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-01 · updated 2026-09-01
- Weakness: CWE-400
Description
axios versions 0.28.0 and later contain uncontrolled recursion in formDataToJSON when processing FormData field names with deeply nested bracket segments. Attackers can supply FormData with field names containing thousands of nested brackets to exhaust the JavaScript call stack and trigger RangeError, causing request failure or process termination in applications that do not handle the exception.
Affected products
- axios: from 0.28.0 before 1.18.0 — fixed in 1.18.0
How to fix
Upgrade to a fixed version: axios 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/axios/axios/security/advisories/GHSA-42h9-826w-cgv3
- https://www.vulncheck.com/advisories/axios-before-denial-of-service-via-formdatatojson
- https://github.com/axios/axios/security/advisories/GHSA-42h9-826w-cgv3
Get alerted when CVE-2026-67313 or the next vulnerability affects your stack