What’s Vulnerable › Vulnerabilities
CVE-2026-67315: axios 0.31.0 before 0.33.0 and 1.15.0 before 1.18.0 NO_PROXY Bypass via 0.0.0.0
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-01 · updated 2026-09-01
- Weakness: CWE-183
Description
axios versions 0.31.0 before 0.33.0 and 1.15.0 before 1.18.0 fail to recognize 0.0.0.0 as a loopback address in shouldBypassProxy.js, allowing requests to 0.0.0.0 to bypass NO_PROXY rules. Attackers can supply 0.0.0.0 URLs to route requests through configured proxies, potentially exposing local services when the proxy can reach the destination.
Affected products
- axios: from 0.31.0 before 0.33.0; from 1.15.0 before 1.18.0 — fixed in 0.33.0, 1.18.0
How to fix
Upgrade to a fixed version: axios 0.33.0, 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/axios/axios/security/advisories/GHSA-f4gw-2p7v-4548
- https://www.vulncheck.com/advisories/axios-before-no-proxy-bypass-via
Get alerted when CVE-2026-67315 or the next vulnerability affects your stack