What’s Vulnerable › Vulnerabilities
CVE-2026-67321: axios 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 Denial of Service via maxDepth bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-01 · updated 2026-09-01
- Weakness: CWE-674
Description
axios versions 0.31.1 before 0.33.0 and 1.15.1 before 1.18.0 contain an incomplete depth-limit bypass in toFormData.js when serializing objects with top-level keys ending in '{}'. Attackers who control object keys and nested values passed to axios form or parameter serialization can trigger a RangeError from JSON.stringify, causing denial of service in the affected request path.
Affected products
- axios: from 0.31.1 before 0.33.0; from 1.15.1 before 1.18.0 — fixed in 0.33.0, 1.18.0
How to fix
Upgrade to a fixed version: axios 0.33.0, 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/axios/axios/security/advisories/GHSA-hcpx-6fm6-wx23
- https://www.vulncheck.com/advisories/axios-before-denial-of-service-via-maxdepth-bypass
- https://github.com/axios/axios/security/advisories/GHSA-hcpx-6fm6-wx23
Get alerted when CVE-2026-67321 or the next vulnerability affects your stack