What’s Vulnerable › Vulnerabilities

CVE-2026-67327: better-auth before 1.6.22 Account Takeover via Magic-Link Email-OTP

Description

better-auth versions >= 1.1.3 and < 1.6.22 (and pre-release versions >= 1.7.0-beta.0 and < 1.7.0-beta.10) are vulnerable to account takeover via pre-account hijacking on magic-link and email-OTP sign-in when open email/password registration is enabled. An attacker registers an account with the victim's email address and an attacker-chosen password; the account remains unverified. When the legitimate owner later signs in via the magic-link or email-OTP passwordless flow, the account is marked verified without removing the pre-existing password or revoking existing sessions, so the attacker's password remains valid, granting persistent access to the victim's account. Fixed in 1.6.22 and 1.7.0-beta.10.

Affected products

How to fix

Upgrade to a fixed version: better-auth 1.6.22, 1.7.0-beta.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-67327 or the next vulnerability affects your stack