What’s Vulnerable › Vulnerabilities
CVE-2026-67328: @better-auth/sso before 1.6.21 Account Takeover via SSO
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-23
- Weakness: CWE-79
Description
@better-auth/sso versions before 1.6.21 contain multiple authentication bypass vulnerabilities in SSO provider handling that allow attackers to sign in as arbitrary users. Attackers can exploit domain verification parsing mismatches, orphaned provider accounts, unbound SAML assertions, or reflected XSS on logout endpoints to gain unauthorized session access and account takeover.
Affected products
- better-auth sso: before 1.6.21; from 1.7.0-beta.0 before 1.7.0-beta.10 — fixed in 1.6.21, 1.7.0-beta.10
How to fix
Upgrade to a fixed version: better-auth sso 1.6.21, 1.7.0-beta.10. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-prpr-5gj3-qqhg
- https://www.vulncheck.com/advisories/better-auth-sso-before-account-takeover-via-sso
Get alerted when CVE-2026-67328 or the next vulnerability affects your stack