What’s Vulnerable › Vulnerabilities
CVE-2026-67335: better-auth before 1.6.2 OAuth State Validation Bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-09-08
- Weakness: CWE-287
Description
better-auth versions before 1.6.2 fail to validate the OAuth state parameter against the stored nonce when using cookie-backed state storage without PKCE. Attackers can forge the state parameter and supply an attacker-controlled authorization code to create authenticated sessions bound to the attacker's external identity or persistently link attacker accounts to victim profiles.
Affected products
- better-auth: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: better-auth 1.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-wxw3-q3m9-c3jr
- https://www.vulncheck.com/advisories/better-auth-before-oauth-state-validation-bypass
Get alerted when CVE-2026-67335 or the next vulnerability affects your stack