What’s Vulnerable › Vulnerabilities
CVE-2026-67336: better-auth before 1.6.11 Insecure Cryptographic Defaults via oidcProvider
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-09-08
- Weakness: CWE-327
Description
better-auth versions before 1.6.11 contain insecure cryptographic defaults in the oidcProvider and mcp plugins that advertise the none algorithm and accept plain PKCE by default. Attackers can exploit algorithm negotiation to accept unsigned tokens or intercept authorization codes when PKCE plain is used instead of the required S256 method.
Affected products
- better-auth: before 1.6.11 — fixed in 1.6.11
How to fix
Upgrade to a fixed version: better-auth 1.6.11. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-9h47-pqcx-hjr4
- https://www.vulncheck.com/advisories/better-auth-before-insecure-cryptographic-defaults-via-oidcprovider
Get alerted when CVE-2026-67336 or the next vulnerability affects your stack