What’s Vulnerable › Vulnerabilities
CVE-2026-67337: better-auth before 1.4.9 Two-Factor Authentication Bypass via session.cookieCache
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-09-08
- Weakness: CWE-288
Description
better-auth versions before 1.4.9 contain a two-factor authentication bypass vulnerability when session.cookieCache is enabled. Attackers with valid primary credentials can access authenticated routes without completing second-factor verification by exploiting premature session caching.
Affected products
- better-auth: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: better-auth 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/better-auth/better-auth/security/advisories/GHSA-xg6x-h9c9-2m83
- https://www.vulncheck.com/advisories/better-auth-before-two-factor-authentication-bypass-via-session-cookiecache
Get alerted when CVE-2026-67337 or the next vulnerability affects your stack