What’s Vulnerable › Vulnerabilities
CVE-2026-67338: JupyterLab before 4.5.9 Stored XSS via Extension Manager
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-08
- Weakness: CWE-84
Description
JupyterLab before 4.5.9 contains a stored cross-site scripting vulnerability in the Extension Manager that fails to validate URI protocols in package metadata URLs. Attackers can publish malicious PyPI packages with javascript: URLs in project metadata that execute arbitrary JavaScript in the JupyterLab origin when users click the extension name.
Affected products
- jupyterlab: before 4.5.9 — fixed in 4.5.9
How to fix
Upgrade to a fixed version: jupyterlab 4.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterlab/jupyterlab/commit/4e61e07d0a91145b53fbf96ac74b0387f6bc51f6
- https://github.com/jupyterlab/jupyterlab/commit/d5d961f6e10a6442dddbf94d9a976b3897055a12
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-vmhf-c436-hxj4
- https://www.vulncheck.com/advisories/jupyterlab-before-stored-xss-via-extension-manager
Get alerted when CVE-2026-67338 or the next vulnerability affects your stack