What’s Vulnerable › Vulnerabilities
CVE-2026-67340: ArcadeDB before 26.7.2 Remote Code Execution via Trigger Scripts
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-23
- Weakness: CWE-94
Description
ArcadeDB before 26.7.2 (arcadedb-engine) allows trigger scripts to look up host classes in java.lang.* (via Java.type) because ScriptTriggerExecutor adds java.lang.* to the allowed packages. An authenticated user with UPDATE_SCHEMA permission can create a JavaScript trigger that invokes java.lang.Runtime.getRuntime().exec() (or ProcessBuilder), achieving OS command execution when the trigger fires.
Affected products
- ArcadeData arcadedb: before 26.7.2 — fixed in 26.7.2
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-x9f9-r4m8-9xc2
- https://www.vulncheck.com/advisories/arcadedb-before-remote-code-execution-via-trigger-scripts
Get alerted when CVE-2026-67340 or the next vulnerability affects your stack