What’s Vulnerable › Vulnerabilities
CVE-2026-67341: ArcadeDB before 26.7.2 Authorization Bypass via SQL DEFINE FUNCTION
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-23
- Weakness: CWE-863
Description
ArcadeDB versions before 26.7.2 fail to enforce scripting authorization checks on the SQL DEFINE FUNCTION statement with LANGUAGE js. Attackers with database access can execute arbitrary JavaScript code by submitting DEFINE FUNCTION statements, bypassing security controls intended to restrict scripting to administrators.
Affected products
- ArcadeData arcadedb: before 26.7.2 — fixed in 26.7.2
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-vwjc-v7x7-cm6g
- https://www.vulncheck.com/advisories/arcadedb-before-authorization-bypass-via-sql-define-function
Get alerted when CVE-2026-67341 or the next vulnerability affects your stack