What’s Vulnerable › Vulnerabilities
CVE-2026-67353: guzzlehttp/guzzle before 7.15.1 Unbounded Cookie Denial of Service
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-10-08
- Weakness: CWE-770
Description
guzzlehttp/guzzle versions before 7.15.1 contain a denial of service vulnerability in the CookieJar that accepts unlimited Set-Cookie header fields with no size restrictions. Attackers can return many large cookies from a malicious server, causing Guzzle to store excessive data in memory and generate oversized Cookie headers that fail in handlers or destination servers.
Affected products
- Packagist Guzzlehttp/Guzzle: before 7.15.1; 4.0.0, 4.0.0-rc.1, 4.0.0-rc.2, 4.0.1, 4.0.2, 4.1.0 (+168) — fixed in 7.15.1
- guzzle: before 7.15.1 — fixed in 7.15.1
How to fix
Upgrade to a fixed version: Packagist Guzzlehttp/Guzzle 7.15.1; guzzle 7.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/guzzle/guzzle/security/advisories/GHSA-f283-ghqc-fg79
- https://www.vulncheck.com/advisories/guzzlehttp-guzzle-before-unbounded-cookie-denial-of-service
Get alerted when CVE-2026-67353 or the next vulnerability affects your stack