What’s Vulnerable › Vulnerabilities
CVE-2026-67356: ArcadeDB before 26.7.3 Privilege Escalation via JavaScript Trigger
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-02 · updated 2026-10-23
- Weakness: CWE-269
Description
ArcadeDB before 26.7.3 binds the real LocalDatabase object into JavaScript trigger contexts with HostAccess.ALL, allowing schema-admins to call getSecurity().createUser() without permission checks. Attackers with UPDATE_SCHEMA permission can create triggers that execute JavaScript to create server-wide admin users, escalating privileges beyond their authorization level.
Affected products
- ArcadeData arcadedb: before 26.7.3 — fixed in 26.7.3
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-38pf-6hp2-pxww
- https://www.vulncheck.com/advisories/arcadedb-before-privilege-escalation-via-javascript-trigger
Get alerted when CVE-2026-67356 or the next vulnerability affects your stack