What’s Vulnerable › Vulnerabilities
CVE-2026-6736: Authentication bypass vulnerability in GitHub Enterprise Server allowed creation of local user accounts bypassing the configured external identity provider
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-306
Description
An authentication bypass vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to create a local user account, bypassing the configured external identity provider. When external authentication was enabled, the signup endpoint did not properly enforce the authentication restriction, allowing account creation and session establishment without identity provider validation. The created account was limited to the default base permissions configured on the instance. Exploitation required network access to a GHES instance configured with an external authentication provider. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18.
Affected products
- GitHub Enterprise Server: before 3.16.18; from 3.17.0 before 3.17.15; from 3.18.0 before 3.18.9; from 3.19.0 before 3.19.6; from 3.20.0 before 3.20.2 — fixed in 3.16.18, 3.17.15, 3.18.9, 3.19.6, 3.20.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.16.18, 3.17.15, 3.18.9, 3.19.6. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.18
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.15
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.9
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.6
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.2
Get alerted when CVE-2026-6736 or the next vulnerability affects your stack