What’s Vulnerable › Vulnerabilities

CVE-2026-6739: Mattermost: Delegated admins could patch protected default system roles

Description

Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to require system-level permission when patching protected default system roles, which allows authenticated users with delegated user-management permissions to escalate privileges by altering built-in role permissions via the role patch API.. Mattermost Advisory ID: MMSA-2026-00656

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.17, 11.5.5, 11.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-6739 or the next vulnerability affects your stack