What’s Vulnerable › Vulnerabilities
CVE-2026-67411: RabbitMQ: Web MQTT with PROXY Protocol enabled: a loopback-only user permission bypass
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-25 · updated 2026-10-08
- Weakness: CWE-863
Description
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.18, 4.0.23, 4.1.14, 4.2.9, and 4.3.3, native MQTT and MQTT over WebSocket behind a trusted PROXY Protocol frontend could lose the proxy-derived client address before the MQTT authentication path checked loopback_users, causing the frontend-to-broker address to be treated as loopback. An attacker who can reach the trusted frontend and has valid credentials for a loopback-restricted account can therefore bypass the source-address restriction; the issue does not bypass password authentication. This issue is fixed in versions 3.13.18, 4.0.23, 4.1.14, 4.2.9, and 4.3.3.
Affected products
- rabbitmq-server: from 3.13.0 before 3.13.18; from 4.0.0 before 4.0.23; from 4.1.0 before 4.1.14; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.3 — fixed in 3.13.18, 4.0.23, 4.1.14, 4.2.9, 4.3.3
How to fix
Upgrade to a fixed version: rabbitmq-server 3.13.18, 4.0.23, 4.1.14, 4.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/a7528314840c4f8dc9904684f9f97ffa7aac6349
- https://github.com/rabbitmq/rabbitmq-server/commit/edbead0eabbd65925d0dc914a22d6a29e155e646
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-4r6f-9cpw-f6g6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-4r6f-9cpw-f6g6
Get alerted when CVE-2026-67411 or the next vulnerability affects your stack