What’s Vulnerable › Vulnerabilities
CVE-2026-67412: RabbitMQ: Federation upstream skips vhost authorization allowing cross-vhost message access
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-25 · updated 2026-10-08
- Weakness: CWE-862
Description
RabbitMQ is a messaging and streaming broker. From 3.13.0 until 4.3.3, 4.2.9 , 4.1.14, 4.0.24, and 3.13.18, Federation upstream in RabbitMQ skips vhost authorization allowing cross-vhost message access. what the bug lets you do. A policymaker on one vhost reads and drains messages out of another vhost it has no permission on. With the default ack-mode the source messages are consumed (deleted), not copied. Why that should not 1. Federation validates the upstream URI without any vhost-access Cross-vhost message read/drain from a per-vhost policymaker, breaking vhost tenancy This issue is fixed in versions 4.3.3, 4.2.9 , 4.1.14, 4.0.24, and 3.13.18.
Affected products
- rabbitmq-server: from 3.13.0 before 3.13.18; from 4.0.0 before 4.0.24; from 4.1.0 before 4.1.14; from 4.2.0 before 4.2.9; from 4.3.0 before 4.3.3 — fixed in 3.13.18, 4.0.24, 4.1.14, 4.2.9, 4.3.3
How to fix
Upgrade to a fixed version: rabbitmq-server 3.13.18, 4.0.24, 4.1.14, 4.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-42pc-678q-v8qj
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-42pc-678q-v8qj
Get alerted when CVE-2026-67412 or the next vulnerability affects your stack