What’s Vulnerable › Vulnerabilities
CVE-2026-67591: Apache Qpid ProtonJ2: Incoming session flow control window can be exceeded
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-10-24
- Weakness: CWE-770
Description
An authenticated attacker could exceed the session flow control incoming window potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Qpid ProtonJ2: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Qpid ProtonJ2 1.2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/rwmggh2bkm6qotxpdfcplht3jgw5n036
- http://www.openwall.com/lists/oss-security/2026/08/04/30
Get alerted when CVE-2026-67591 or the next vulnerability affects your stack