What’s Vulnerable › Vulnerabilities
CVE-2026-67593: Apache Artemis, Apache Artemis, Apache ActiveMQ Artemis, Apache ActiveMQ Artemis: Pre-authentication Openwire protocol handling can result in queue deletion
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-16
- Weakness: CWE-306
Description
A remote attacker can craft an Openwire RemoveSubscriptionInfo command to cause the deletion of a queue on the Artemis broker before the connection authentication and authorization stage or at any time thereafter. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache ActiveMQ Artemis: from 1.0.0 before 2.44.0; from 2.50.0 before 2.57.0 — fixed in 2.44.0, 2.57.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ActiveMQ Artemis 2.44.0, 2.57.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/zlglnsg8s5xv8n56d15dm5mf00h2d8xs
- http://www.openwall.com/lists/oss-security/2026/09/10/6
Get alerted when CVE-2026-67593 or the next vulnerability affects your stack