What’s Vulnerable › Vulnerabilities
CVE-2026-68408: wifi: cfg80211: convert pmsr_free_wk to wiphy_work to fix deadlock
- Severity: unknown
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: cfg80211: convert pmsr_free_wk to wiphy_work to fix deadlock When a netlink socket that owns a PMSR session is closed, cfg80211_release_pmsr() clears the request's nl_portid and queues pmsr_free_wk to call cfg80211_pmsr_process_abort() asynchronously. If the interface tears down concurrently, cfg80211_pmsr_wdev_down() is called under wiphy_lock and calls cancel_work_sync(&pmsr_free_wk) to wait for any running work. The work function acquires wiphy_lock via guard(wiphy) before calling process_abort. This is a deadlock: wdev_down holds wiphy_lock and blocks inside cancel_work_sync(); pmsr_free_wk blocks trying to acquire that same wiphy_lock. Neither thread can proceed. The same deadlock is reachable from cfg80211_leave_locked(), which calls cfg80211_pmsr_wdev_down() for all interface types under wiphy_lock. Fix this by converting pmsr_free_wk from a plain work_struct to a wiphy_work. The wiphy_work dispatcher holds wiphy_lock when running work items, so the explicit guard(wiphy) in the work function is no longer needed. wiphy_work_cancel() can be called safely while holding wiphy_lock - since wiphy_lock prevents the work from running concurrently, wiphy_work_cancel() never blocks, eliminating the deadlock. Remove the cancel_work_sync() for pmsr_free_wk from the NETDEV_GOING_DOWN handler. cfg80211_leave(), called unconditionally just before it, already cancels any pending work under wiphy_lock via wiphy_work_cancel() inside cfg80211_pmsr_wdev_down().
Affected products
- Linux: from 6.1.167 before 6.1.191; from 6.6.130 before 6.6.160; from 6.12.78 before 6.12.101; from 6.18.20 before 6.18.42; from 6.19.10 before 6.20 — fixed in 6.1.191, 6.6.160, 6.12.101, 6.18.42, 6.20
How to fix
Upgrade to a fixed version: Linux 6.1.191, 6.6.160, 6.12.101, 6.18.42. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0a77d9fb4d5c0e01306cd406ffdee8f1fe955c0e
- https://git.kernel.org/stable/c/133684982dd0c24359fcc641d19d89cc17d6e5ef
- https://git.kernel.org/stable/c/21512b5f7a74fd18c996c22e6854efe57d570816
- https://git.kernel.org/stable/c/2b0eab425e1f658d8fe1df7590e3b9af5959505e
- https://git.kernel.org/stable/c/30c67926d41c456809857976cd3cd71b2290e0c1
- https://git.kernel.org/stable/c/efe47df4de5e3e19b0670c5f2f67bdc4c9dc02af
Get alerted when CVE-2026-68408 or the next vulnerability affects your stack