What’s Vulnerable › Vulnerabilities
CVE-2026-68520: Glances: as_dict_secure() Value-Level Bypass Leaks Credentials in URL Values via /api/4/config
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-17 · updated 2026-10-23
- Weakness: CWE-200
Description
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, as_dict_secure() in glances/config.py checks only option names and exposes public_username and credentials embedded in public_api values through unauthenticated GET /api/4/config and GET /api/4/config/ip requests. This issue is fixed in 4.5.6.
Affected products
- nicolargo glances: before 4.5.6
References
- https://github.com/nicolargo/glances/commit/8d0f8276c2abd2e9d400bd6c84bdfba0dfcab065
- https://github.com/nicolargo/glances/releases/tag/v4.5.6
- https://github.com/nicolargo/glances/security/advisories/GHSA-4h34-v6r8-mmjc
- https://github.com/nicolargo/glances/security/advisories/GHSA-4h34-v6r8-mmjc
Get alerted when CVE-2026-68520 or the next vulnerability affects your stack