What’s Vulnerable › Vulnerabilities
CVE-2026-68570: Apache Doris: Authorization bypass leading to unauthorized data access
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-14
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access data they are not authorized to read, resulting in unauthorized disclosure of information. This issue affects Apache Doris: from 2.0.0 through 2.1.*, from 3.0.0 through 3.0.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4. Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.
Affected products
- Apache Software Foundation Apache Doris: 2.1.x from 2.0.0; 3.0.x from 3.0.0; from 4.0.0 before 4.0.8; from 4.1.0 before 4.1.4 — fixed in 4.0.8, 4.1.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Doris 4.0.8, 4.1.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/rp2gr6d7rb4y8slxh3fojmhb1rl5ms03
- http://www.openwall.com/lists/oss-security/2026/09/14/2
Get alerted when CVE-2026-68570 or the next vulnerability affects your stack