What’s Vulnerable › Vulnerabilities
CVE-2026-6871: Obfuscate - Moderately critical - Cross-site scripting - SA-CONTRIB-2026-033
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Obfuscate allows Cross-Site Scripting (XSS). This issue affects Obfuscate: from 0.0.0 before 2.0.2.
Affected products
- Obfuscate Project Obfuscate: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: Obfuscate Project Obfuscate 2.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6871 or the next vulnerability affects your stack