What’s Vulnerable › Vulnerabilities
CVE-2026-68939: Pyenv: Glob/wildcard metacharacters bypass is_version_safe(), causing silent version/interpreter substitution via unquoted expansion (CVE-2022-35861 residual)
- Severity: low (CVSS 2.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-09-18
- Weakness: CWE-78
Description
Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.
Affected products
- pyenv: before 2.8.0
References
- https://github.com/pyenv/pyenv/commit/95df7dbc7b34595b47c9b922de198547effda819
- https://github.com/pyenv/pyenv/releases/tag/v2.8.0
- https://github.com/pyenv/pyenv/security/advisories/GHSA-g478-f579-9vp9
- https://github.com/pyenv/pyenv/security/advisories/GHSA-g478-f579-9vp9
Get alerted when CVE-2026-68939 or the next vulnerability affects your stack