What’s Vulnerable › Vulnerabilities
CVE-2026-69077: Apache Kylin: JobController allows unauthorized cross-project manipulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-20
- Weakness: CWE-200
Description
Exposure of unauthorized cross-project job manipulation vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 4..0.0 through 5.0.4
References
- https://lists.apache.org/thread.html/wcc7w3lbhfcgb51p867shv1d513z7x1t
- http://www.openwall.com/lists/oss-security/2026/10/16/9
Get alerted when CVE-2026-69077 or the next vulnerability affects your stack