What’s Vulnerable › Vulnerabilities
CVE-2026-69080: Apache Kylin: Broken Access Control in QuerySQLBlacklistController
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-16 · updated 2026-10-20
- Weakness: CWE-200
Description
Exposure of SQL Black List to an Unauthorized Actor vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 4..0.0 through 5.0.4
References
- https://lists.apache.org/thread.html/zrt6z545y8z9qtsbyzfy55sdpf75osnp
- http://www.openwall.com/lists/oss-security/2026/10/16/10
Get alerted when CVE-2026-69080 or the next vulnerability affects your stack