What’s Vulnerable › Vulnerabilities
CVE-2026-69097: GitPython before 3.1.53 Config Injection via Submodule Names
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-03 · updated 2026-10-23
- Weakness: CWE-74
Description
GitPython before 3.1.53 fails to properly escape section names in git config files, allowing attackers to inject arbitrary configuration directives through malicious submodule names. Attackers can inject core.sshCommand or other dangerous config keys into the victim's .git/config via create_submodule or clone_from operations, achieving remote code execution when git performs ssh operations.
Affected products
- gitpython-developers GitPython: before 3.1.53 — fixed in 3.1.53
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.53. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-3rp5-jjmw-4wv2
- https://www.vulncheck.com/advisories/gitpython-before-config-injection-via-submodule-names
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-3rp5-jjmw-4wv2
Get alerted when CVE-2026-69097 or the next vulnerability affects your stack