What’s Vulnerable › Vulnerabilities
CVE-2026-69116: FlyEnv < 4.18.0 Cross-Site Scripting via v-html
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-79
Description
FlyEnv before 4.18.0 fails to sanitize HTML from markdown rendering and AI chat content passed to Vue v-html directives. Attackers can inject malicious scripts through markdown sources or chat messages that execute in the Electron renderer process with access to Node.js APIs and the filesystem.
Affected products
- xpf0000 FlyEnv: before 4.18.0 — fixed in 4.18.0
How to fix
Upgrade to a fixed version: xpf0000 FlyEnv 4.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/xpf0000/FlyEnv/commit/68fd6d7b200273ad0a8bce09424b8bd87134cfb6
- https://github.com/xpf0000/FlyEnv/issues/809
- https://github.com/xpf0000/FlyEnv/pull/810
- https://github.com/xpf0000/FlyEnv/releases/tag/v4.18.0
- https://www.vulncheck.com/advisories/flyenv-cross-site-scripting-via-v-html
Get alerted when CVE-2026-69116 or the next vulnerability affects your stack