What’s Vulnerable › Vulnerabilities
CVE-2026-6914: MD5 checksum creation may cause availability loss
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-29 · updated 2026-10-26
- Weakness: CWE-191
Description
Computing the MD5 checksum of a malformed BSON object under specific conditions may cause loss of availability in MongoDB server. This issue affects all MongoDB Server v8.2 versions, all MongoDB Server v8.1 versions, MongoDB Server v8.0 versions prior to 8.0.21, MongoDB Server v7.0 versions prior to 7.0.32
Affected products
- MongoDB: from 7.0.0 before 7.0.32; from 8.0.0 before 8.0.21; from 8.1.0 before 8.2.7 — fixed in 7.0.32, 8.0.21, 8.2.7
How to fix
Upgrade to a fixed version: MongoDB 7.0.32, 8.0.21, 8.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6914 or the next vulnerability affects your stack