What’s Vulnerable › Vulnerabilities
CVE-2026-6915: Flaw in the updateUser Command May Allow Unauthorized Configuration Change
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-29 · updated 2026-10-26
- Weakness: CWE-1284
Description
An authorization flaw in the user management command could allow an authenticated user to make limited changes to authentication-related data associated with another user account. This could affect how authentication is performed for the impacted account.
Affected products
- MongoDB: from 7.0.0 before 7.0.32; from 8.0.0 before 8.0.21; from 8.2.0 before 8.2.7 — fixed in 7.0.32, 8.0.21, 8.2.7
How to fix
Upgrade to a fixed version: MongoDB 7.0.32, 8.0.21, 8.2.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6915 or the next vulnerability affects your stack