What’s Vulnerable › Vulnerabilities
CVE-2026-69151: Angular i18n: Cross-Site Scripting (XSS) via event-handler attributes
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-08-11
- Weakness: CWE-79
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.
Affected products
- angular: through 19.2.25; from 20.0.0 before 20.3.27; from 21.0.0 before 21.2.19; from 22.0.0 before 22.0.1 — fixed in 20.3.27, 21.2.19, 22.0.1
How to fix
Upgrade to a fixed version: angular 20.3.27, 21.2.19, 22.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/commit/417a4071a776464d549509ed3aec121dbd2fda5e
- https://github.com/angular/angular/commit/6c41f5ca01c0ae045fc7d929b72853a11eb55865
- https://github.com/angular/angular/pull/68821
- https://github.com/angular/angular/pull/69306
- https://github.com/angular/angular/security/advisories/GHSA-jj27-h5hq-8x99
Get alerted when CVE-2026-69151 or the next vulnerability affects your stack