What’s Vulnerable › Vulnerabilities

CVE-2026-69152: brace-expansion: DoS via unbounded intermediate arrays, bypassing the CVE-2026-14257 mitigation

Description

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

Affected products

How to fix

Upgrade to a fixed version: juliangruber brace-expansion 1.1.18, 2.1.4, 3.0.6, 5.0.9; Npm Brace-Expansion 1.1.18, 2.1.4, 3.0.6, 5.0.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-69152 or the next vulnerability affects your stack