What’s Vulnerable › Vulnerabilities
CVE-2026-6918
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-05 · updated 2026-10-26
- Weakness: CWE-125
Description
In Eclipse Open9J versions 0.21 to 0.58, a pre-authentication remote attacker can crash JITServer by sending a 32-byte crafted TCP message.
Affected products
- The Eclipse Foundation Eclipse OpenJ9: from 0.21.0 before 0.59.0 — fixed in 0.59.0
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse OpenJ9 0.59.0. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-openj9/openj9/pull/23793
- https://github.com/eclipse-openj9/openj9/security/advisories/GHSA-q393-vr4c-969r
- https://access.redhat.com/errata/RHSA-2026:22328
- https://access.redhat.com/security/cve/CVE-2026-6918
- https://bugzilla.redhat.com/show_bug.cgi?id=2466741
- https://github.com/eclipse-openj9/openj9/security/advisories/GHSA-q393-vr4c-969r
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-6918.json
Get alerted when CVE-2026-6918 or the next vulnerability affects your stack