What’s Vulnerable › Vulnerabilities

CVE-2026-69234: reflected cross site scripting vulnerability in Esri Portal for ArcGIS

Description

There is a reflected cross site scripting vulnerability in Esri Portal for ArcGIS versions 11.5 and prior which may allow a remote, unauthenticated attacker to create a crafted link which when clicked could potentially execute arbitrary JavaScript code in the victim’s browser. Users working with ArcGIS Enterprise 11.1, 11.3, and 11.5 are encouraged to patch. All users are advised to upgrade to the latest long-term support release. Users working with ArcGIS Web App Builder developer edition are advised to migrate to ArcGIS Experience Builder, as ArcGIS Web App Builder developer edition is unsupported when this CVE is assigned.

Affected products

How to fix

Upgrade to a fixed version: Esri Portal for ArcGIS 11.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-69234 or the next vulnerability affects your stack