What’s Vulnerable › Vulnerabilities
CVE-2026-69249: python-cryptography: Duplicate self-signed intermediates can cause exponential path-building
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-03 · updated 2026-10-23
- Weakness: CWE-400
Description
python-cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 42.0.0 through 48.0.0, when resolving invalid certificate chains that include duplicate copies of self-signed certificates, the processing recursively invokes the same candidate, leading to an exponential blowup. Although the limitation that the chain depth cannot exceed a specified maximum depth prevents unbounded recursion and guarantees termination, an attacker-controlled certificate chain can lead the processing to easily take more than 5s to reject in testing. This amplification could form the basis for a resource exhaustion denial of service attack. The core issue arises in the recursive nature of build_chain_inner, which does not de-duplicate against previously analyzed candidates. As the correctness of validation is not affected, the integrity of a system cannot be compromised through this vector, only its availability. This issue is fixed in 49.0.0.
Affected products
- Pypi Cryptography: before 49.0.0; 0.1, 0.2, 0.2.1, 0.2.2, 0.3, 0.4 (+150) — fixed in 49.0.0
- pyca cryptography: from 42.0.0, < 49.0.0
How to fix
Upgrade to a fixed version: Pypi Cryptography 49.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/pyca/cryptography/commit/3763aa79b
- https://github.com/pyca/cryptography/commit/4a12cf49675a184e47f912b00b04f3a629283582
- https://github.com/pyca/cryptography/pull/14960
- https://github.com/pyca/cryptography/security/advisories/GHSA-jwv3-5hgf-82ww
- https://github.com/pypa/advisory-database/tree/main/vulns/cryptography/PYSEC-2026-3553.yaml
- https://github.com/pyca/cryptography/security/advisories/GHSA-jwv3-5hgf-82ww
Get alerted when CVE-2026-69249 or the next vulnerability affects your stack